[Skip to content]

.

Credit Card Payments

Recent increases in the number of SSL related exploits have forced the PCI Security Standards Council to introduce new controls which are mandatory for organisations processing credit card payments.

One of these requirements is to reject what are considered to be insecure connections to services.

In order to comply with this mandatory requirement, we will be making some changes to our online payments service on 27th November 2015.  After this date any connections from older web browsers will be rejected.  Connections will only be possible from the following web browsers:

  • Internet Explorer - v11 and above
  • Chrome - v22 and above
  • Firefox - v27 and above
  • Opera - v14 and above
  • Safari - v7 and above

We recommend that you update your web browser to the latest version available in order to continue using our online payments service. It is also possible to reconfigure some earlier web browsers to continue connecting to this service, although this is not a recommended workaround and is beyond the scope of this advisory.